Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
9.8
CVE-2008-7315: Debian libui-dialog-perl can run commands remotely
CVE-2008-7315 · published 9 years ago
Summary
The libui-dialog-perl package in Debian versions 1.09 and earlier can be tricked into running any command an attacker sends over the network. This could let an outsider take control of the system or steal data. Update the package to a newer version or remove it if it is not needed.
What to do
- Update debian libui-dialog-perl to version 1.21-0.1.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| Debian:12 | debian | libui-dialog-perl |
< 1.21-0.1 Fix: upgrade to 1.21-0.1
|
| Debian:13 | debian | libui-dialog-perl |
< 1.21-0.1 Fix: upgrade to 1.21-0.1
|
| Debian:14 | debian | libui-dialog-perl |
< 1.21-0.1 Fix: upgrade to 1.21-0.1
|
| – | cpan | ui\ |
\ cpe:2.3:a:cpan:ui\:\:dialog:0.01:*:*:*:*:*:*:* |
Original advisory text
UI-Dialog 1.09 and earlier allows remote attackers to execute arbitrary commands.
UI-Dialog 1.09 and earlier allows remote attackers to execute arbitrary commands.
References
- https://security-tracker.debian.org/tracker/CVE-2008-7315 Vendor Advisory
- http://www.openwall.com/lists/oss-security/2015/10/08/6 Mailing List Third Party Advisory
- http://www.securityfocus.com/bid/77031/info Third Party Advisory VDB Entry
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=496448 Third Party Advisory
- https://rt.cpan.org/Public/Bug/Display.html?id=107364 Vendor Advisory
- https://security-tracker.debian.org/tracker/CVE-2008-7315/ Third Party Advisory
Severity
9.8
Critical
Type
CWE-77Command Injection
Timeline
Published10 Oct 2017
Updated4 Nov 2026
First seen20 Sep 2026
Track software like this
Free during beta