Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
4.3

CVE-2008-4130: Gallery allows attackers to run scripts via Flash

CVE-2008-4130 · published 18 years ago
Summary

Versions of Gallery before 2.2.6 let a malicious Flash file place code on your web pages. This can let an attacker make the site show false information or steal user data. Update Gallery to version 2.2.6 or later, or remove Flash uploads until you can apply the fix.

What to do

The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.

Affected software
VendorProductAffected versions
gallery gallery <= 2.2.5
2.2.0
2.2.1
2.2.2
2.2.3
2.2.4
cpe:2.3:a:gallery:gallery:*:*:*:*:*:*:*:*
Original advisory text
Cross-site scripting (XSS) vulnerability in Gallery 2.x before 2.2.6 allows remote attackers to inject arbitrary web script or HTML via a crafted Flash animation, related to the ability of the anim...
Cross-site scripting (XSS) vulnerability in Gallery 2.x before 2.2.6 allows remote attackers to inject arbitrary web script or HTML via a crafted Flash animation, related to the ability of the animation to "interact with the embedding page."
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
4.3 Medium
Exploitation
2% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published18 Sep 2008
Updated3 Nov 2026
First seen29 Sep 2026
Sources
CVE-2008-4130 · NVD
Track software like this
Free during beta