Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
10.0

CVE-2008-3533: Yelp help viewer can run malicious code via crafted link

CVE-2008-3533 · published 18 years ago
Summary

Versions of the Yelp help viewer included in GNOME before 2.24 can be tricked into executing code when they open a specially formed web address. An attacker could embed such an address in a web page, email, or other program and cause the victim’s computer to run the attacker’s code. Install the latest Debian yelp package or apply the security update that fixes the issue.

What to do
  • Update debian yelp to version 2.22.1-4.
  • Update gnome yelp to version 2.24 or later.
Affected software
Ecosystem VendorProductAffected versions
Debian:12 debian yelp < 2.22.1-4
Fix: upgrade to 2.22.1-4
Debian:13 debian yelp < 2.22.1-4
Fix: upgrade to 2.22.1-4
Debian:14 debian yelp < 2.22.1-4
Fix: upgrade to 2.22.1-4
– gnome yelp < 2.24
cpe:2.3:a:gnome:yelp:*:*:*:*:*:*:*:*
– gnome gnome 2.20
2.22
cpe:2.3:a:gnome:gnome:2.20:*:*:*:*:*:*:*
Original advisory text
Format string vulnerability in the window_error function in yelp-window.c in yelp in Gnome after 2.19.90 and before 2.24 allows remote attackers to execute arbitrary code via format string specifie...
Format string vulnerability in the window_error function in yelp-window.c in yelp in Gnome after 2.19.90 and before 2.24 allows remote attackers to execute arbitrary code via format string specifiers in an invalid URI on the command line, as demonstrated by use of yelp within (1) man or (2) ghelp URI handlers in Firefox, Evolution, and unspecified other programs.
Severity
10.0 Critical
Exploitation
19% chance of attack within 30 days
Type
CWE-134Use of Externally-Controlled Format String
Timeline
Published18 Aug 2008
Updated19 Oct 2026
First seen20 Sep 2026
Sources
CVE-2008-3533 · NVD
Track software like this
Free during beta