Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.5

CVE-2008-2502: eMule X‑Ray web server can be remotely corrupted

CVE-2008-2502 · published 18 years ago
Summary

The web server component in eMule X‑Ray versions prior to 1.4 can be attacked from the network, causing its memory to become corrupted. This could lead to the server crashing or being taken over by an attacker. Upgrade to version 1.4 or later, or apply the vendor’s patch, to protect your system.

What to do

The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.

Affected software
VendorProductAffected versions
emule x_ray <= 1.2
cpe:2.3:a:emule:x_ray:*:*:*:*:*:*:*:*
Original advisory text
Unspecified vulnerability in the web server in eMule X-Ray before 1.4 allows remote attackers to trigger memory corruption via unknown attack vectors.
Unspecified vulnerability in the web server in eMule X-Ray before 1.4 allows remote attackers to trigger memory corruption via unknown attack vectors.
Fix within
Internet-facing 14 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically (estimated)
  • Gives an attacker partial control (estimated)
Severity
7.5 High
Exploitation
1% chance of attack within 30 days
Type
CWE-399Resource Management Errors
Timeline
Published29 May 2008
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2008-2502 · NVD
Track software like this
Free during beta