Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
10.0

CVE-2008-0318: ClamAV <0.92.1 can be crashed or hijacked

CVE-2008-0318 · published 18 years ago
Summary

The ClamAV antivirus package used on Debian systems can be tricked by a specially crafted Windows executable file sent to the clamd scanner. This can make the scanner stop working and, in some cases, allow an attacker to run their own code on the server. Upgrade ClamAV to version 0.92.1 or later to eliminate the risk.

What to do
  • Update debian clamav to version 0.92.1~dfsg-1.
Affected software
Ecosystem VendorProductAffected versions
Debian:12 debian clamav < 0.92.1~dfsg-1
Fix: upgrade to 0.92.1~dfsg-1
Debian:13 debian clamav < 0.92.1~dfsg-1
Fix: upgrade to 0.92.1~dfsg-1
Debian:14 debian clamav < 0.92.1~dfsg-1
Fix: upgrade to 0.92.1~dfsg-1
– clam_anti-virus clamav <= 0.92
cpe:2.3:a:clam_anti-virus:clamav:*:*:*:*:*:*:*:*
Original advisory text
Integer overflow in the cli_scanpe function in libclamav in ClamAV before 0.92.1, as used in clamd, allows remote attackers to cause a denial of service and possibly execute arbitrary code via a cr...
Integer overflow in the cli_scanpe function in libclamav in ClamAV before 0.92.1, as used in clamd, allows remote attackers to cause a denial of service and possibly execute arbitrary code via a crafted Petite packed PE file, which triggers a heap-based buffer overflow.
References
Severity
10.0 Critical
Exploitation
8% chance of attack within 30 days
Type
CWE-189Numeric Errors
Timeline
Published12 Feb 2008
Updated15 Oct 2026
First seen20 Sep 2026
Sources
CVE-2008-0318 · NVD
Track software like this
Free during beta