Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.2

CVE-2007-5729: QEMU 0.8.2 NE2000 emulation can let local users run code

CVE-2007-5729 · published 19 years ago
Summary

The QEMU virtualization program version 0.8.2 includes a network‑adapter emulator (NE2000) that can be tricked into overflowing its memory when a local user sends an overly large Ethernet frame. This memory overflow can allow the attacker to run any program they choose on the host machine. Update QEMU to a newer version or apply the vendor’s patch to stop the problem.

What to do
  • Update debian qemu to version 0.9.0-2.
Affected software
Ecosystem VendorProductAffected versions
Debian:12 debian qemu < 0.9.0-2
Fix: upgrade to 0.9.0-2
Debian:13 debian qemu < 0.9.0-2
Fix: upgrade to 0.9.0-2
Debian:14 debian qemu < 0.9.0-2
Fix: upgrade to 0.9.0-2
– qemu qemu 0.8.2
cpe:2.3:a:qemu:qemu:0.8.2:*:*:*:*:*:*:*
– debian debian_linux 3.1
4.0
cpe:2.3:o:debian:debian_linux:3.1:*:*:*:*:*:*:*
– opensuse opensuse 11.0
11.1
cpe:2.3:o:opensuse:opensuse:11.0:*:*:*:*:*:*:*
Original advisory text
The NE2000 emulator in QEMU 0.8.2 allows local users to execute arbitrary code by writing Ethernet frames with a size larger than the MTU to the EN0_TCNT register, which triggers a heap-based buffe...
The NE2000 emulator in QEMU 0.8.2 allows local users to execute arbitrary code by writing Ethernet frames with a size larger than the MTU to the EN0_TCNT register, which triggers a heap-based buffer overflow in the slirp library, aka NE2000 "mtu" heap overflow. NOTE: some sources have used CVE-2007-1321 to refer to this issue as part of "NE2000 network driver and the socket code," but this is the correct identifier for the mtu overflow vulnerability.
Severity
7.2 High
Exploitation
<1% chance of attack within 30 days
Type
CWE-119Buffer Overflow
Timeline
Published30 Oct 2007
Updated4 Nov 2026
First seen28 Sep 2026
Sources
CVE-2007-5729 · NVD
Track software like this
Free during beta