Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
9.8
CVE-2007-5341: Firefox before 2.0.0.8 allows remote code execution
CVE-2007-5341 · published 9 years ago
Summary
A flaw in the Venkman script debugger in older Firefox versions can let an attacker run code on a user’s computer from a web page. This could let the attacker take control of the browser or install unwanted software. Upgrade Firefox to version 2.0.0.8 or later, or disable the Venkman debugger, to protect against this risk.
What to do
The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| mozilla | firefox |
<= 2.0.0.7 cpe:2.3:a:mozilla:firefox:*:*:*:*:*:*:*:* |
Original advisory text
Remote code execution in the Venkman script debugger in Mozilla Firefox before 2.0.0.8.
Remote code execution in the Venkman script debugger in Mozilla Firefox before 2.0.0.8.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=325761 Issue Tracking Vendor Advisory
- https://bugzilla.mozilla.org/show_bug.cgi?id=345305 Issue Tracking Vendor Advisory
- https://bugzilla.suse.com/show_bug.cgi?id=332512 Issue Tracking Third Party Advisory VDB Entry
Internet-facing
3 days
Internal
60 days
- Not known to be exploited
- Can be exploited automatically (estimated)
- Gives an attacker full control (estimated)
Type
CWE-119Buffer Overflow
Timeline
Published18 Aug 2017
Updated31 Oct 2026
First seen29 Sep 2026
Sources
CVE-2007-5341 · NVD
Track software like this
Free during beta