Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
4.3

CVE-2007-4189: Joomla! 1.0.12 lets attackers run malicious code in browsers

CVE-2007-4189 · published 19 years ago
Summary

Versions of Joomla! older than 1.0.13 let a remote attacker place harmful script or HTML into search, content or login pages. When a user visits a compromised page, the attacker’s code can run in the user’s browser, potentially stealing data or hijacking the session. Update Joomla! to version 1.0.13 or later, or apply the vendor’s patches, to stop this risk.

What to do
  • Update joomla joomla\! to version 1.0.13 or later.
Affected software
VendorProductAffected versions
joomla joomla\! < 1.0.13
cpe:2.3:a:joomla:joomla\!:*:*:*:*:*:*:*:*
Original advisory text
Multiple cross-site scripting (XSS) vulnerabilities in Joomla! before 1.0.13 (aka Sunglow) allow remote attackers to inject arbitrary web script or HTML via unspecified vectors in the (1) com_searc...
Multiple cross-site scripting (XSS) vulnerabilities in Joomla! before 1.0.13 (aka Sunglow) allow remote attackers to inject arbitrary web script or HTML via unspecified vectors in the (1) com_search, (2) com_content, and (3) mod_login components. NOTE: some of these details are obtained from third party information.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
4.3 Medium
Exploitation
2% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published8 Aug 2007
Updated3 Nov 2026
First seen29 Sep 2026
Sources
CVE-2007-4189 · NVD
Track software like this
Free during beta