Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.5
CVE-2006-7109: Drupal IMCE module lets logged‑in users upload malicious PHP
CVE-2006-7109 · published 19 years ago
Summary
The IMCE file‑upload feature in Drupal versions before 1.6 lets a user who is signed in upload a file that contains PHP code by using a double extension like .php.gif. This could let an attacker place and run their own code on your website, potentially taking control of the site. Update the IMCE module to version 1.6 or later, or disable file uploads for untrusted users until the update is applied.
What to do
The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| drupal | imce_module |
<= 1.5 cpe:2.3:a:drupal:imce_module:*:*:*:*:*:*:*:* |
Original advisory text
Unrestricted file upload vulnerability in IMCE before 1.6, a Drupal module, allows remote authenticated users to upload arbitrary PHP code via a filename with a double extension such as .php.gif.
Unrestricted file upload vulnerability in IMCE before 1.6, a Drupal module, allows remote authenticated users to upload arbitrary PHP code via a filename with a double extension such as .php.gif.
References
- http://drupal.org/node/87101 Patch Vendor Advisory
- http://secunia.com/advisories/22261 Patch Vendor Advisory
- http://www.vupen.com/english/advisories/2006/3892
- https://exchange.xforce.ibmcloud.com/vulnerabilities/29325
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker partial control (estimated)
Severity
6.5
Medium
Timeline
Published5 Mar 2007
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2006-7109 · NVD
Track software like this
Free during beta