Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.8
CVE-2006-6522: WikiTimeScale TwoZero lets attackers run scripts
CVE-2006-6522 · published 19 years ago
Summary
The WikiTimeScale TwoZero web application (versions before 2.31) can be tricked into executing malicious code entered into forum posts or event descriptions. This could let an attacker display unwanted content, steal user data, or hijack user sessions. Update to version 2.31 or later, or apply the vendor’s provided patches, to stop the issue.
What to do
The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| wikitimescale | twozero |
2.04 2.05 2.22 2.23 2.24 2.30 cpe:2.3:a:wikitimescale:twozero:2.04:*:*:*:*:*:*:* |
Original advisory text
Multiple cross-site scripting (XSS) vulnerabilities in WikiTimeScale TwoZero before 2.31 allow remote attackers to inject arbitrary web script or HTML via unspecified vectors in the (1) forum modul...
Multiple cross-site scripting (XSS) vulnerabilities in WikiTimeScale TwoZero before 2.31 allow remote attackers to inject arbitrary web script or HTML via unspecified vectors in the (1) forum module and (2) event descriptions. NOTE: some of these details are obtained from third party information.
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker partial control (estimated)
Severity
6.8
Medium
Timeline
Published14 Dec 2006
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2006-6522 · NVD
Track software like this
Free during beta