Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
4.3

CVE-2006-0650: cpaint library lets attackers run malicious script

CVE-2006-0650 · published 20 years ago
Summary

The cpaint library versions before 2.0.3 can include attacker‑supplied code in an error message, causing the browser to execute it. This happens when a specially crafted value is sent to the cpaint_response_type field. Upgrade to version 2.0.3 or later, or apply the vendor's patch, to stop the injection.

What to do

The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.

Affected software
VendorProductAffected versions
cpaint cpaint 1.0
1.01
1.2
1.3
1.3_sp
1.3_sp1
2.0.0
2.0.1
2.0.2
pre1.0
cpe:2.3:a:cpaint:cpaint:1.0:*:*:*:*:*:*:*
Original advisory text
Cross-site scripting (XSS) vulnerability in cpaint2.inc.php in the CPAINT library before 2.0.3, as used in multiple scripts, allows remote attackers to inject arbitrary web script or HTML via the c...
Cross-site scripting (XSS) vulnerability in cpaint2.inc.php in the CPAINT library before 2.0.3, as used in multiple scripts, allows remote attackers to inject arbitrary web script or HTML via the cpaint_response_type parameter, which is displayed in a resulting error message, as demonstrated using a hex-encoded IFRAME tag.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
4.3 Medium
Exploitation
2% chance of attack within 30 days
Timeline
Published13 Feb 2006
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2006-0650 · NVD
Track software like this
Free during beta