Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.5

CVE-2005-4470: Blender BlenLoader 2.0-2.40pre Crash and Code Execution Risk via .blend Files

CVE-2005-4470 · published 20 years ago
Summary

A security issue in Blender BlenLoader 2.0 to 2.40pre could allow an attacker to crash the application or potentially take control of it by sending a malicious .blend file. This issue affects users who open .blend files from untrusted sources, such as the internet. Update to a fixed version to resolve this issue.

What to do
  • Update debian blender to version 2.40-1.
Affected software
Ecosystem VendorProductAffected versions
Debian:11 debian blender < 2.40-1
Fix: upgrade to 2.40-1
Debian:12 debian blender < 2.40-1
Fix: upgrade to 2.40-1
Debian:13 debian blender < 2.40-1
Fix: upgrade to 2.40-1
Debian:14 debian blender < 2.40-1
Fix: upgrade to 2.40-1
– blender blenloader <= 2.40_pre
2.0
2.04
2.25
2.26
2.27
2.28
2.28a
2.28c
2.30
2.31a
2.32
8 more version ranges
cpe:2.3:a:blender:blenloader:*:*:*:*:*:*:*:*
Original advisory text
Heap-based buffer overflow in the get_bhead function in readfile.c in Blender BlenLoader 2.0 through 2.40pre allows remote attackers to cause a denial of service (application crash) and possibly ex...
Heap-based buffer overflow in the get_bhead function in readfile.c in Blender BlenLoader 2.0 through 2.40pre allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a .blend file with a negative bhead.len value, which causes less memory to be allocated than expected, possibly due to an integer overflow.
Severity
7.5 High
Exploitation
6% chance of attack within 30 days
Timeline
Published22 Dec 2005
Updated4 Nov 2026
First seen28 Jul 2026
Sources
CVE-2005-4470 · NVD
Track software like this
Free during beta