Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
7.5
CVE-2005-3540: petris before 1.0.1 can let attackers run code
CVE-2005-3540 · published 20 years ago
Summary
The version of the petris program that comes with Debian prior to 1.0.1 has a coding mistake that can be triggered from outside the system, allowing a hacker to make the program do whatever they want. This could let them take control of the server or steal data. Upgrade to version 1.0.1 or newer as soon as possible, and verify the update was applied correctly.
What to do
- Update debian petris to version 1.0.1-5.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| Debian:12 | debian | petris |
< 1.0.1-5 Fix: upgrade to 1.0.1-5
|
| Debian:13 | debian | petris |
< 1.0.1-5 Fix: upgrade to 1.0.1-5
|
| Debian:14 | debian | petris |
< 1.0.1-5 Fix: upgrade to 1.0.1-5
|
| – | petris | petris |
<= 1.0.1 cpe:2.3:a:petris:petris:*:*:*:*:*:*:*:* |
Original advisory text
Buffer overflow in petris before 1.0.1 allows remote attackers to execute arbitrary code via unspecified attack vectors.
Buffer overflow in petris before 1.0.1 allows remote attackers to execute arbitrary code via unspecified attack vectors.
Severity
7.5
High
Timeline
Published31 Dec 2005
Updated31 Oct 2026
First seen26 Sep 2026
Track software like this
Free during beta