Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.5

CVE-2005-3392: PHP before 4.4.1 lets attackers ignore safety settings on Apache

CVE-2005-3392 · published 21 years ago
Summary

If you run an old version of PHP (earlier than 4.4.1) with Apache, a remote user could get around the safe_mode and open_basedir limits that normally keep scripts from accessing files they shouldn't. This could allow them to read or modify sensitive files on your server. Upgrade PHP to version 4.4.1 or newer, or apply any available security patches and review your configuration.

What to do

The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.

Affected software
VendorProductAffected versions
php php 3.0
3.0.1
3.0.2
3.0.3
3.0.4
3.0.5
3.0.6
3.0.7
3.0.8
3.0.9
3.0.10
3.0.11
36 more version ranges
cpe:2.3:a:php:php:3.0:*:*:*:*:*:*:*
Original advisory text
Unspecified vulnerability in PHP before 4.4.1, when using the virtual function on Apache 2, allows remote attackers to bypass safe_mode and open_basedir directives.
Unspecified vulnerability in PHP before 4.4.1, when using the virtual function on Apache 2, allows remote attackers to bypass safe_mode and open_basedir directives.
Fix within
Internet-facing 14 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically (estimated)
  • Gives an attacker partial control (estimated)
Severity
7.5 High
Exploitation
7% chance of attack within 30 days
Timeline
Published1 Nov 2005
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2005-3392 · NVD
Track software like this
Free during beta