Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
7.5
CVE-2005-2949: pam_per_user before 0.4 can let attackers impersonate users
CVE-2005-2949 · published 21 years ago
Summary
The pam_per_user module version earlier than 0.4 does not check if the username changes during a login attempt and reuses the same request handle. This flaw lets a remote attacker or someone with local access log in as a different user by exploiting programs that allow the username to be changed, such as the standard login command. Upgrade to version 0.4 or later to protect against this risk.
What to do
The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| mark_d._roth | pam_per_user |
0.1 0.2 0.3 cpe:2.3:a:mark_d._roth:pam_per_user:0.1:*:*:*:*:*:*:* |
Original advisory text
pam_per_user before 0.4 does not verify if the user name changes between authentication attempts and uses the same subrequest handle, which allows remote attackers or local users to login as other ...
pam_per_user before 0.4 does not verify if the user name changes between authentication attempts and uses the same subrequest handle, which allows remote attackers or local users to login as other users by using certain applications that allow the username to be changed during authentication, such as /bin/login.
References
Internet-facing
14 days
Internal
60 days
- Not known to be exploited
- Can be exploited automatically (estimated)
- Gives an attacker partial control (estimated)
Severity
7.5
High
Timeline
Published16 Sep 2005
Updated3 Nov 2026
First seen29 Sep 2026
Sources
CVE-2005-2949 · NVD
Track software like this
Free during beta