Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
7.5
CVE-2005-1349: Debian libconvert-uulib-perl lets attackers run code
CVE-2005-1349 · published 21 years ago
Summary
The libconvert-uulib-perl library used in Debian can be tricked into running any program an attacker chooses if it receives specially crafted input. This could let a remote user take control of your server. Update the package to the latest version or apply the vendor’s security patch as soon as possible.
What to do
- Update debian libconvert-uulib-perl to version 1.0.5.1.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| Debian:12 | debian | libconvert-uulib-perl |
< 1.0.5.1 Fix: upgrade to 1.0.5.1
|
| Debian:13 | debian | libconvert-uulib-perl |
< 1.0.5.1 Fix: upgrade to 1.0.5.1
|
| Debian:14 | debian | libconvert-uulib-perl |
< 1.0.5.1 Fix: upgrade to 1.0.5.1
|
| – | perl | convert_uulib |
<= 1.050 cpe:2.3:a:perl:convert_uulib:*:*:*:*:*:*:*:* |
Original advisory text
Buffer overflow in Convert-UUlib (Convert::UUlib) before 1.051 allows remote attackers to execute arbitrary code via a malformed parameter to a read operation.
Buffer overflow in Convert-UUlib (Convert::UUlib) before 1.051 allows remote attackers to execute arbitrary code via a malformed parameter to a read operation.
References
- https://security-tracker.debian.org/tracker/CVE-2005-1349 Vendor Advisory
- http://secunia.com/advisories/15130 Patch
- http://www.gentoo.org/security/en/glsa/glsa-200504-26.xml
- http://www.mandriva.com/security/advisories?name=MDKSA-2006:022
- http://www.securityfocus.com/bid/13401
- https://exchange.xforce.ibmcloud.com/vulnerabilities/20275
Severity
7.5
High
Timeline
Published2 May 2005
Updated17 Oct 2026
First seen26 Sep 2026
Track software like this
Free during beta