Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
7.2
CVE-2004-0984: mailutils on Debian may let attackers gain higher privileges
CVE-2004-0984 · published 21 years ago
Summary
The mailutils package included with Debian releases before version 1:0.5-4 has a flaw in its file‑locking code. An attacker who can influence mail processing could exploit this to act with more system rights than intended. Upgrade mailutils to the latest package version or apply the security update provided by Debian to close the gap.
What to do
- Update debian mailutils to version 1:0.5-4.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| Debian:12 | debian | mailutils |
< 1:0.5-4 Fix: upgrade to 1:0.5-4
|
| Debian:13 | debian | mailutils |
< 1:0.5-4 Fix: upgrade to 1:0.5-4
|
| Debian:14 | debian | mailutils |
< 1:0.5-4 Fix: upgrade to 1:0.5-4
|
| – | gnu | mailutils |
<= 1.0.5.4 cpe:2.3:a:gnu:mailutils:*:*:*:*:*:*:*:* |
Original advisory text
Unknown vulnerability in the dotlock implementation in mailutils before 1:0.5-4 on Debian GNU/Linux allows attackers to gain privileges.
Unknown vulnerability in the dotlock implementation in mailutils before 1:0.5-4 on Debian GNU/Linux allows attackers to gain privileges.
Severity
7.2
High
Timeline
Published31 Dec 2004
Updated4 Nov 2026
First seen15 Sep 2026
Track software like this
Free during beta