Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.2

CVE-2004-0884: Cyrus-SASL 2.1.18 lets local users run malicious code

CVE-2004-0884 · published 21 years ago
Summary

The Cyrus-SASL authentication libraries used in Debian can be tricked by a local user who changes a system setting called SASL_PATH, causing the software to load and run the user’s own program. This could let that user execute any code they want on the server. Update the Cyrus-SASL package to a newer version or restrict the SASL_PATH setting to trusted locations to prevent the misuse.

What to do
  • Update debian cyrus-sasl2 to version 2.1.19-1.3.
Affected software
Ecosystem VendorProductAffected versions
Debian:12 debian cyrus-sasl2 < 2.1.19-1.3
Fix: upgrade to 2.1.19-1.3
Debian:13 debian cyrus-sasl2 < 2.1.19-1.3
Fix: upgrade to 2.1.19-1.3
Debian:14 debian cyrus-sasl2 < 2.1.19-1.3
Fix: upgrade to 2.1.19-1.3
– cyrus sasl 1.5.24
1.5.27
1.5.28
2.1.9
2.1.10
2.1.11
2.1.12
2.1.13
2.1.14
2.1.15
2.1.16
2.1.17
2 more version ranges
cpe:2.3:a:cyrus:sasl:1.5.24:*:*:*:*:*:*:*
– conectiva linux 9.0
10.0
cpe:2.3:o:conectiva:linux:9.0:*:*:*:*:*:*:*
Original advisory text
The (1) libsasl and (2) libsasl2 libraries in Cyrus-SASL 2.1.18 and earlier trust the SASL_PATH environment variable to find all available SASL plug-ins, which allows local users to execute arbitra...
The (1) libsasl and (2) libsasl2 libraries in Cyrus-SASL 2.1.18 and earlier trust the SASL_PATH environment variable to find all available SASL plug-ins, which allows local users to execute arbitrary code by modifying the SASL_PATH to point to malicious programs.
Severity
7.2 High
Exploitation
<1% chance of attack within 30 days
Timeline
Published27 Jan 2005
Updated4 Nov 2026
First seen15 Sep 2026
Sources
CVE-2004-0884 · NVD
Track software like this
Free during beta