Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.2

CVE-2002-1896: Alsaplayer can let local users run any code

CVE-2002-1896 · published 23 years ago
Summary

If Alsaplayer version 0.99.71 is installed so it always runs with administrator privileges, a regular user can start it with a crafted command line and cause it to execute whatever program they choose. This could give that user higher access on the system. Remove the set‑administrator setting, upgrade to a fixed version, or uninstall Alsaplayer if it is not needed.

What to do
  • Update debian alsaplayer to version 0.99.72-1.
Affected software
Ecosystem VendorProductAffected versions
Debian:12 debian alsaplayer < 0.99.72-1
Fix: upgrade to 0.99.72-1
Debian:13 debian alsaplayer < 0.99.72-1
Fix: upgrade to 0.99.72-1
Debian:14 debian alsaplayer < 0.99.72-1
Fix: upgrade to 0.99.72-1
– alsaplayer alsaplayer 0.99.71
cpe:2.3:a:alsaplayer:alsaplayer:0.99.71:*:*:*:*:*:*:*
Original advisory text
Buffer overflow in Alsaplayer 0.99.71, when installed setuid root, allows local users to execute arbitrary code via a long (1) -f or (2) -o command line argument.
Buffer overflow in Alsaplayer 0.99.71, when installed setuid root, allows local users to execute arbitrary code via a long (1) -f or (2) -o command line argument.
Severity
7.2 High
Exploitation
2% chance of attack within 30 days
Timeline
Published31 Dec 2002
Updated3 Nov 2026
First seen16 Sep 2026
Sources
CVE-2002-1896 · NVD
Track software like this
Free during beta