Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
7.5
CVE-2001-1229: Icecast and libshout can crash or be hijacked
CVE-2001-1229 · published 25 years ago
Summary
Versions of Icecast older than 1.3.9 and libshout older than 1.0.4 contain a coding mistake that lets an attacker send specially crafted data to make the service stop working or run their own code. This could disrupt your streaming service or give an attacker control of the server. Upgrade Icecast to 1.3.9 or later and libshout to 1.0.4 or later to eliminate the risk.
What to do
The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| icecast | icecast |
<= 1.3.9 cpe:2.3:a:icecast:icecast:*:*:*:*:*:*:*:* |
| libshout | libshout |
<= 1.0.4 cpe:2.3:a:libshout:libshout:*:*:*:*:*:*:*:* |
Original advisory text
Buffer overflows in (1) Icecast before 1.3.9 and (2) libshout before 1.0.4 allow remote attackers to cause a denial of service (crash) and execute arbitrary code.
Buffer overflows in (1) Icecast before 1.3.9 and (2) libshout before 1.0.4 allow remote attackers to cause a denial of service (crash) and execute arbitrary code.
Internet-facing
14 days
Internal
60 days
- Not known to be exploited
- Can be exploited automatically (estimated)
- Gives an attacker partial control (estimated)
Severity
7.5
High
Timeline
Published12 Mar 2001
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2001-1229 · NVD
Track software like this
Free during beta